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QuoteWerks Knowledgebase Topic (Article ID 7676)

General - WinPDF or product license expiring or expired upon startup

This information applies to :

Article ID
7676

Created/Updated
September 8, 2023

Category
Updates


Are you using the most current release of QuoteWerks?
Version 24.0 Build 4
Issue:
Upon startup, QuoteWerks is announcing that the WinPDF driver is an Evaluation Version and it about to expire or is expired. The system might also report a bad product license, or invalid version, with a license key unlike standard QuoteWerks licensing.

This issue tends to crop up more when upgrading from Version 4.9 to Version 5.x and higher, as QuoteWerks received a massive print engine update in Version 5.0 Build 4.x.


Cause:
This issue is due to the fact that the files were in use during the update, or for whatever reason, they were not overwritten during the update. It is actually easy to resolve.


Solution:

You will need to locate the hts19.dll (could go back as far as 14 depending on your version), ter22.dll (or ter19.dll depending on your version), the pdc32.dll, hps32.dll, rep8.dll (or rep9.dll for higher versions) and wps32.dll on your system. If this is a 64-bit system, then the files probably reside in the ..\Windows\SysWow64\ directory, otherwise you will find them in the ..\Windows\system32 directory.

Rename the files to *.old. It is also possible to simply delete the files.

While the mentioned files often reside in the System folders, there are some cases where they ended up elsewhere on the system (such as the User folders in the case of an improper installation on a terminal server). Please make sure that the system is scoured and ALL instances of the mentioned files are removed from the system.

Then run the Nsetup from the QuoteWerks directory again. Your issue should be resolved.

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Customer-friendly version that can be used as a canned doc:
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- Ensure QuoteWerks is closed on this machine. If QuoteWerks is installed to a terminal or remote desktop server, make sure ALL users are not logged into QuoteWerks.
- Head over to the C:\Windows\SysWOW64 folder.
- You'll want to search for the following files and delete them:

DebenuPDFLibraryAX1115.dll
HPCC.DLL
HPS32.DLL
HTS14.DLL
HTS18.DLL
PDC32.DLL
REP8.DLL
REP9.DLL
ROC8.OCX
TER17.DLL
TER18.DLL
TER19.DLL
TER22.DLL
TER23.DLL
TOC17.OCX
TOC19.OCX
ViewPDF03.ocx
wp_type1ttf.dll
WPCC.DLL
wPDFView03.dll
WPS32.DLL
WRS3.DLL
WRS7.DLL

- If your QuoteWerks is in a terminal or remote desktop environment, you may also want to a global search for the above files that may be located in user specific folders. If so delete all of those as well.
- If your QuoteWerks is in a terminal or remote desktop environment, open an ADMINISTRATIVE command prompt window (Click start, type in Run, right click the shortcut and click Run as Administrator), and type in:

change user /install

then press Enter on your keyboard. You should get a confirmation message. Minimize the window, you'll need it in a moment.
- (For all installation types) Then open up your main QuoteWerks folder, find and run nsetup.exe. Complete the install.
- If your QuoteWerks is in a terminal or remote desktop environment, head back to the administrative command prompt window and type in:

change user /execute

then press Enter on your keyboard. You should get a confirmation message. You can then close the window.
- Run QuoteWerks, you should be good to go at this point.



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